Arquivo da tag: Software

Soma condicional no Excel?

A dúvida abaixo veio do Artur:

“Karlão preciso somar várias células com números, só que células do lado desta contém expressões tipo ‘PAGO’ ou ‘EM ABERTO’, quero que a fórmula só some valores aonde a condição seja ‘PAGO’, como faço?”

Artur, sua dúvida é bem interessante. Vou explicar duas formas de fazer isto no Excel (qualquer versão). O que você deseja fazer chama-se Soma Condicional, o próprio nome já explica, você quer somar determinados valores, desde que uma determinada condição seja confirmada, neste caso PAGO ou EM ABERTO. Vou usar uma tabela semelhante a sua como exemplo, segue abaixo:

Neste exemplo, queremos somar os valores da coluna B, desde que estes estejam pagos (condição da coluna C). Vamos ao que interessa. A fómula a ser usada chama-se SOMASE. Esta fórmula pede 3 informações: Intervalo, Condição e Intervalo da Soma. O intervalo é a coluna (ou linha) aonde a fórmula irá procurar pela condição, a Condição é justamente o que a fórmula vai procurar (e caso encontrar) irá executar a soma. Por último, o Intervalo da Soma é justamente a coluna com os valores que queremos somar.

No nosso exemplo temos: Intervalo (coluna C), Condição (“PAGO”) e Intervalo da Soma (Coluna B). A fórmula fica então assim: =SOMASE(C2:C7;”PAGO”;B2:B7). Importante notar que como o conteúdo da coluna C é texto, a palavra PAGO tem que ser colocada entre aspas na fórmula.

A outra forma de realizar a soma condicional é através de um suplemento (plugin) do Excel. Este plugin está incluso em todas as versões do Excel. Nos casos das versões mais antigas, o mesmo já vem ativado, basta ir no menu “Ferramentas” e em seguida na opção “Soma Condicional”. Já no Excel 2007, você precisa acessar o botão do Office no lado esquerdo superior da tela, clicar em “Opções do Excel”, ir até a seção de “Suplementos” e ativar o “Assistente de Soma Condicional”. Feito a ativação, a opção de soma condicional estará dentro da aba “Fórmulas”.

O assistente nada mais é do que uma interface gráfica para que você possa criar somas condicionais simples ou até mesmo complexas. Basta seguir o passo a passo e ler cuidadosamente as explicações na tela. Não tem segredo!

Mais linhas no Excel 2007?

A dúvida abaixo veio do Victor:

“Karlão, tenho uma planilha complexa em Excel 2003, quando abro ela no Excel 2007 quero que a mesma tenha mais linhas do que o valor limite de 65536, o que devo fazer?”

Victor, sua dúvida é um bom complemento ao post anterior que fiz sobre o assunto. O Excel 2003 e anteriores possuem um limite claro de 65536 linhas, não sendo possível ultrapassar este valor em uma mesma planilha. Já o Excel 2007 possui um limite dezesseis vezes maior que este, um total incrível de 1048576 linhas. Porém, este limite só está disponível para arquivos salvos no formato do Excel 2007 (.xlsx).

Portanto, mesmo que você abra seu arquivo .xls do Excel 2003, no novo Office 2007, ele vai continuar tendo o limite de 65536, mas basta você salvar o mesmo no novo formato (através do menu Salvar Como), fechar o Excel e abrir a nova planilha salva (no formato .xlsx) que o limite irá passar para o número milionário acima. Simples né ? Tome cuidado porém com planilhas muito complexas que podem perder certas funcionalidades no formato novo, o Excel 2007 inclusive informa automaticamente as possíveis incompatibilidades antes de realizar a gravação do novo arquivo.

Não variar valor no Excel?

A dúvida abaixo veio do Angel:

“Karlão, como posso copiar e colar uma fórmula no Excel sem alterar parte do seu conteúdo?”

Angel, o procedimento é simples, basta usar o caractere “$” (dólar, sem as aspas). Com isto, o Excel reconheçe que você não quer alterar aquele valor, portanto na hora de copiar e colar ele vai manter estes dados e alterar somente os outros (se ainda existir algo para ser alterado). Para entender melhor, vamos a um exemplo:

1) Somar a célula A1 com a célula B1, você faria desta forma:
=SOMA(A1:B1)

2) Em seguida você deseja usar a mesma fórmula na linha de baixo para somar A2 com B2, basta copiar e colar a fórmula acima, que o Excel automaticamente irá altera para:
=SOMA(A2:B2)

3) Mas no seu caso, você deseja copiar para a linha de baixo, sendo que o primeiro valor a ser somado é sempre o A1, ou seja, em cada linha o A1 será somado com B1, B2, B3, etc. Então você faz da seguinte forma:
=SOMA($A$1:B1)

Neste caso, o Excel não irá variar nem a coluna A, nem a linha 1 no momento da cópia, mantendo sempre A1. Caso você deseje que a coluna seja variada, mas não a linha, então basta usar:
=SOMA(A$1:B1)

Neste último exemplo, o “A” irá variar, mas o “1” não. Você pode “brincar” com o “$” em diversas situações, principalmente em fórmulas matemáticas no Excel, os exemplos acima foram somente para ilustrar algumas destas situações.

Lixeira deletada no Vista?

A dúvida abaixo veio do grande amigo Claytin:“Karlão, apaguei o ícone da lixeira do meu desktop no Windows Vista, como faço para recuperá-lo?”

Claytin, o procedimento é muito simples. Clique com o botão direito na sua área de trabalho e acesse a opção “Personalizar”. Na nova janela, do lado esquerdo abaixo do menu “Tarefas” clique na opção “Alterar ícones da Área de Trabalho”. Pronto, na nova janela basta marcar o ícone da Lixeira que o mesmo irá aparecer novamente no Desktop.

É interessante mencionarmos que o Vista permite apagar o ícone da lixeira facilmente, já no Windows XP, o ícone da Lixeira não podia ser removido, somente através da edição do Registro ou em Políticas de Grupo avançadas.

Office 2007 no Office 2003?

A dúvida abaixou veio do Flávio:

“Karlão, existe alguma forma de abrir arquivos do Office 2007 em versões anteriores do Office, como a 2003 e XP?”

A resposta é sim, de uma forma simples e fácil. É bom deixarmos claro que somente os arquivos salvos no formato padrão do Microsoft Office 2007 (.docx, .xlsx, pptx, etc) não conseguem ser abertos em versões anteriores do Office. Porém o Office 2007 permite que os arquivos sejam salvos no formato antigo (.doc, .xls, .ppt, etc) e isto faz com que os arquivos sejam abertos em qualquer outra versão do Office.

Porém, como sempre acontece, muitas vezes recebemos um arquivo no formato Office 2007 e não temos o software para poder salvá-lo em outro formato. Para isto a Microsoft lançou algum tempo atrás um “Pacote de Compatibilidade para arquivos do Office 2007“. Este pacote é grátis e permite que a versão 2003 e XP do Office possam ler arquivos do Office 2007. Lembrando que este programa é feito somente para leitura, não permitindo salvar arquivos no formato novo, mas já ajuda em situações típicas do dia a dia. Basta baixar no link acima e instalá-lo normalmente no seu Windows.